Autodesk just released AutoCAD for Mac 2015, which is fully compatible with Apple's OS X Yosemite. So, if you are upgrading your Mac to Yosemite and are using AutoCAD for Mac 2015 there should be no issues.

Though for users of last years release, AutoCAD for Mac 2014 or earlier, an article over on Architosh points out that maybe you should wait.

Read "IMAGINiT Technologies warns AutoCAD for Mac 2014 not quite ready for Yosemite" for more information.

Have you upgraded to Yosemite or are your critical apps holding you back?